В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
smasa3450
smasa3450
04.03.2023 17:25 •  Информатика

Паскаль 1) составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем. 2) составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1). число n, первый элемент и разность прогрессии вводятся пользователем. вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.

Показать ответ
Ответ:
KekLol89
KekLol89
24.05.2020 23:23

1)

var a: 1000..9999;

      a1, a2, a3, a4: 1..9;//Цифры числа

begin

  writeln('Введите четырехзначное число');

  readln(a);

  a4:= a mod 10; //Последняя цифра

  a3:= (a mod 100) div 10;

  a2:= (a mod 1000) div 100; 

  a1:=a div 1000;//Первая слева цифра

  writeln('Произведение цифр числа: ',a1 * a2 * a3 * a4);

end.

2)

var

  n: integer;

  d, s: real;

  a1: real;

begin

  writeln('Введите число n');

  readln(n);

  writeln('Введите разность прогрессии');

  readln(d);

  writeln('Введите первый элемент');

  readln(a1);

  s:= ((2*a1+d*(n-1))/2)*n;

  writeln('Номер: ', n-1, '     Значение: ', a1+d*(n-2));

  writeln('Номер: ', n, '     Значение: ', a1+d*(n-1));

  writeln('Номер: ', n+1, '     Значение: ', a1+d*n);

  writeln('Сумма ', n, ' первых элементов равна: ',S);

end.

          

  

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота