В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
SIHGFI
SIHGFI
22.07.2021 21:47 •  Информатика

Paskal 1) написать программу с циклом. дана переменная "n", написать программу где все значения "n" будут суммироваться пока n не будет равно 1 2) написать программу с циклом. дана переменная e, нужно выводить "e" в квадрат до тех пор пока "e" не будет равно 100 program test; var.. begin

Показать ответ
Ответ:
Husky333
Husky333
25.06.2020 19:59
Var
    i, n, s: integer;

begin
    read(n);
    for i := n downto 1 do
        s := s + i;
    writeln(s);
end.

2)
var
    i, e: integer;

begin
    write('e = ');
    readln(e);
   
    if e > 100 then
        for i := e downto 100 do
            writeln(i * i)
    else
        for i := e to 100 do
            writeln(i * i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота