В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
301222
301222
15.04.2022 16:07 •  Информатика

Паскаль
1)Написать программу по нахождению суммы N четных чисел. ( S=2+4+6+…+2N).
2) Написать программу для нахождения введенных N чисел (P = P*a).

Показать ответ
Ответ:
HorseOfDeath
HorseOfDeath
23.10.2021 19:48

Бейсик Python

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 100

S = S + 30

N = N * 2

WEND

PRINT S

n = 1

s = 0

while n <= 100:

   s = s + 30

   n = n * 2

print(s)

Паскаль Алгоритмический язык

var n, s: integer;

begin

   n := 1;

   s := 0;

   while n <= 100 do

   begin

       s := s + 30;

       n := n * 2

   end;

   write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 100

   s := s + 30

   n := n * 2

кц

вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

   int n, s;

   n = 1;

   s = 0;

   while (n <= 100)

   {

       s = s + 30;

       n = n * 2;

   }

   cout « s « endl;

}

Объяснение:

0,0(0 оценок)
Ответ:
коаладоби
коаладоби
23.10.2021 19:48

Lazarus-та жоба жасау екі кезеңнен тұрады: жобаның сыртқы пішінін жасау және программалық кодын жазудан тұрады. Жобаның интерфейсін жасауға жоба пішінінің терезесі мен программа кодын жазу редакторын өзара тығыз байланыста қолданамыз. Жоба пішінінің терезесіне жаңа компоненттерді енгізсек, программа кодының құрылымыда автоматты түрде өзгереді. Алғашқы жобаны дайындауды бастайық.

Жоба дайындау төмендегі кезеңдерден тұрады:

1. Пуск – Программы – Lazarus командасын орындап, программа ерезесін ашамыз.

Lazarus терезесі ашылғанда терезеде жоғарыда айтылған мәзір, компонент платформасы, объекттер инспекторы, жоба пішіні терезесі мен программа коды редакторының терезесі пайда болады.

2. Тінтуір арқылы мәзірдегі «Файл=>Создать форму» команда-сын таңдасақ, программа терезесінде «Жоба пішіні» және «Бастапқы код редакторының» терезесі пайда болады (5.5, 5.6-суреттер).

3. «Объекттер инспекторы (Инспектор объектов) => Қасиет (Свойства) => Caption (тақырып)» командаларын таңдап, оған «Жоба пішіні» деп жазып, жобаның тақырыбын өзгертеміз (5.8-сурет).

5.8-сурет. Жоба пішінінің тақырыбын өзгерту

4. «Жоба пішініне» батырма қосу үшін компонент платформасынан «Button1» батырмасын таңдаймыз (5.9-сурет).

5.9-сурет. Пішінге «Button1» батырмасын енгізу

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота