Pascalabc.net если можно то сделайте по простому теперь, когда торговля в городе процветает, пришло время подумать о перспективах. в вашу казну недавно пришло n поступлений по k сентиннеалей. вы решили инвестировать их в промышленность и рассчитываете на ежегодное увеличение своего вложения в m раз. рассчитайте, сколько сентиннеалей у вас будет через х лет. формат входных данных в первой строке вводится целое число денежных поступлений n (1 < = n < = 100) во второй строке вводится n целых чисел k в строчку, где k - каждое из постулений (1< = k < =10000) в третьей строке вводятся целые числа x и m - количество лет, в течении которых будет накапливаться итоговая сумма (1< = x < =10), и число раз, в которые будет увеличиваться сумма каждый год (2< = m < =12) формат выходных данных выводится целое число, равное итоговой сумме накоплений. примеры входные данные 5 2 2 5 4 2 1 2 выходные данные 30
begin
var n:=ReadInteger('n =');
var k:=ReadSeqInteger(n);
var s:=k.Sum;
var (x,m):=ReadInteger2;
writeln(s*power(m,x)); // s*(m**x)
end.
Пример:
5
2 2 5 4 2
3 2
120