В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
justnastya1
justnastya1
10.02.2021 18:46 •  Информатика

PascalABC. Написать программу, в которой выполняются следующие действия:
1. с клавиатуры вводится имя 1-го человека;
2. с клавиатуры вводится вес 1-го человека;
3. с клавиатуры вводится имя 2-го человека;
4. с клавиатуры вводится вес 2-го человека;
5. программа выводит имя более тяжелого человека (при равенстве весов
выводится имя 2-го человека);
6. в том случае, когда вес какого-либо человека или обоих не находится в
пределах от 3 до 150 программа выводит только сообщение «ошибка».

Показать ответ
Ответ:
GizziMix2007
GizziMix2007
15.10.2020 07:18

var

a, b:String;

c, d:Integer;

begin

readln(a);

readln(c);

if (c < 3) or (c  > 150)

then begin

 writeln('Ошибка');

 exit;

 end;

readln(b);

readln(d);

if (d < 3) or (d  > 150)

then begin

 writeln('Ошибка');

 exit;

end;

if c > d then  

 writeln(a)

else  

writeln(b);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота