PASCALABC Написать программу, которая позволит автоматически определить общее число учащихся в классах с 5-й по 10-ю паралель включительно. Для опрелеленности будеи считать, что в каждой параллели не более пяти классов. Число учащихся в классе варьируется от 20 до 30.
Затем перешёл в какой-то подкаталог текущего каталога-Значит он перешёл в папку,которая хранится в папке,в которой хранится Архив,то есть эта папка находится на одном уровне с папкой Архив.
Еще раз перешел в какой-то подкаталог текущего каталога-Значит он перешёл в папку,которая хранится в папке,которая находится на одному уровне с папкой Архив.
С:\Данные\Документы\2009
Значит 2009-Еще раз перешел в какой-то подкаталог текущего каталога
Документы -Затем перешёл в какой-то подкаталог текущего каталога,значит эта папка находится на одном уровне с папкой Архив
Значит искомый адрес:
С:\Данные\Архив
ответ:Вариант 3
program proga;
var st,st2:string;
i:Integer;
begin
writeln('Введите число');
readln(st);
for i:=1 to length(st) do begin
st2:=st[i];
write(st2,' ');
end;
end.
2 задача
program proga2;
var st,st2:string;
i,a:Integer;
begin
writeln('Введите возраст');
readln(a);
if a>120 then
writeln('Неверные данные');
if a=1 then
writeln(a,' год');
if (a>1) and (a<5) then
writeln(a,' года');
if((a mod 10 = 1) and (a div 10 <> 0 or 11 )) then writeln(a,' год');
if (a>=5) and (a mod 10 <> 2 or 3 or 4)and (a div 10 <> 10) then
writeln(a,' лет');
if (a<=5) and (a mod 10 = 2 or 3 or 4)and (a div 10 = 10) then writeln(a,' года ');
if(a>104) and (a<110)then writeln(a,' лет');
end.