В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Inna2404
Inna2404
10.11.2021 19:20 •  Информатика

Pascal: На вход программе подается натуральное число. Нужно переставить чётные цифры в обратном порядке. Например на входе 12345678 на выходе 18365472.

Показать ответ
Ответ:
Qwerty20020505
Qwerty20020505
03.09.2022 02:24

1)

var

 ar: array of integer;

 n, min, max: integer;

begin

 write('Введите размер массива:');

 read(n);

 setlength(ar, n);

 if (n > 0) then  

 begin

   ar[0] := random(-10, 10);

   min := ar[0];

   max := ar[0];

   write(ar[0]:4);

 end;

 for var i := 1 to n - 1 do

 begin

   ar[i] := random(-10, 10);

   if (ar[i] < min) then min := ar[i]

   else if (ar[i] > max) then max := ar[i];

   write(ar[i]:4);

 end;

 writeln(#13#10 + 'Среднее геометрическое модулей минимального и максимального значений = ',  

         sqrt(abs(max) * abs(min)):5:5);

end.

2)

function minOrMax(ar: array of integer; size: integer; findMin: boolean): integer;

var

 index: integer;

begin

 index := 0;

 for var i := 1 to size - 1 do

   if (findMin) and (ar[i] < ar[index]) then index := i

   else if (not findMin) and (ar[i] > ar[index]) then index := i;

 result := index;

end;

3)

function minOrMax(ar: array of integer; size: integer; findMin: boolean): integer;

var

 index: integer;

begin

 index := 0;

 for var i := 1 to size - 1 do

   if (findMin) and (ar[i] < ar[index]) then index := i

   else if (not findMin) and (ar[i] > ar[index]) then index := i;

 result := index;

end;

var

 ar: array of integer;

 n: integer;

begin

 write('Введите размер массива:');

 read(n);

 setlength(ar, n);

 if (n > 0) then  

 begin

   ar[0] := random(-10, 10);

   write(ar[0]:4);

 end;

 for var i := 1 to n - 1 do

 begin

   ar[i] := random(-10, 10);

   write(ar[i]:4);

 end;

 writeln(#13#10 + 'Среднее геометрическое модулей минимального и максимального значений = ',  

         sqrt(abs(ar[minOrMax(ar, n, true)]) * abs(ar[minOrMax(ar, n, false)])):5:5);

end.

0,0(0 оценок)
Ответ:
aregv
aregv
18.07.2021 08:08

4:

var a: array [1..3] of integer;

   i,min,max : integer;

begin

   for i:= 1 to 3 do

   begin

       write('a[',i,'] = ');

       read(a[i]);

       writeln;

   end;

   min:= a[1];

   max:= a[1];

   for i:= 1 to 3 do

   begin

       if a[i] < min then

       begin

           min:= a[i];

       end;

   end;

   for i:= 1 to 3 do

   begin

       if a[i] > max then

       begin

           max:= a[i];

       end;

   end;

   writeln('min = ',min);

   writeln('max = ',max);

end.

5:

var a: array [1..5] of integer;

   i,max : integer;

begin

   for i:= 1 to 5 do

   begin

       write('a[',i,'] = ');

       read(a[i]);

       writeln;

   end;

   max:= a[1];

   for i:= 1 to 3 do

   begin

       if a[i] > max then

       begin

           max:= a[i];

       end;

   end;

   writeln('max = ',max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота