В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Tw1mHero
Tw1mHero
21.11.2020 13:02 •  Информатика

Pascal. для решения используйте используйте цикл с предусловием. постройте блок - схему и напишите программу для нахождения суммы десяти первых элементов ряда.

Показать ответ
Ответ:
Waz4
Waz4
10.06.2022 04:44
Const   n = 50; // количество чиселvar   k: array [1..n] of integer;   i, j, n1, n2, minr, a, b: integer; begin   writeln(n, ' ', ': d');   a : = random(1000);   b : = random(1000);   minr : = 10000;   for i : = 1 to n do       k[i] : = a + random(b);   for i : = 1 to n do       for j : = 1 to n do           if ((abs(k[i] - k[j])) < minr) and (k[i] < > k[j]) then           begin               minr : = abs(k[i] - k[j]);               n1 : = i;               n2 : = j;           end;   writeln(n1, ' ', n2); end.
0,0(0 оценок)
Ответ:
05Karishka0531526654
05Karishka0531526654
26.03.2021 05:13

§1.  о системах счисления.

  n4. развернутая форма записи числа

 

из курса вам известно, что цифры десятичной записи числа – это просто коэффициенты его представления в виде суммы степеней числа – основания системы счисления:

       

      25076 = 2*10000 + 5*1000 + 0*100 + 7*10 + 6*1 = 2*104  +5*103  + 0*102  +7*101+6*100

 

при переводе чисел из десятичной системы счисления в римскую мы и воспользовались этим правилом (444 = 400 + 40 + 4;   2986 = 2000 + 900 + 80 + 6).

при записи чисел значение каждой цифры зависит от ее положения. место для цифры в числе называется разрядом, а количество цифр в числе разрядностью. на самом деле числа можно записывать как сумму степеней не только числа 10, но и любого другого натурального числа, большего 1.

 

определение.  развернутой формой записи числа называется такая запись: а4а3а2а1а0  = а4*q4  + a3*q3  + a2*q2  + a1*q1  + a0*q0  , где а4,а3,а2,а1,а0  –цифры числа, q –основание степени.

 

 

пример1.  получить развернутую форму числа 7512410.

решение:

  а4  = 7, а3  = 5, а2  =1 ,а1  =2, а0  =4,          q=10

 

4 3 2 1 0

75 12410  = 7*104  + 5*103  + 1*102  + 2*101  + 4*100.

 

 

пример2.  получить развернутую форму числа 1123.

решение:

 

2 1 0

1123  = 1*32  + 1*31  +2*30

 

пример3.  получить развернутую  форму числа  176,218.

решение:                     21 0-1-2а8=176, 218=1*82+7*81+6*80+2*8-1+1*8-2  для самостоятельной работы: 1. запишите в развернутом виде числа: а8=143511,62а2=100111а10=143,511а16=1а3,5с12. запишите в свернутой форме число: 9*101+1*100+5*10-1+3*10-2a*162+1*161+c*160+3*16-1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота