Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Xadice12345
30.04.2021 10:45 •
Информатика
Pascal, цикл while или repeat ввести число. найти наибольшую цифру в записи числа.
Показать ответ
Ответ:
Ыыыап
05.10.2020 08:37
Var
n : integer;
max: byte;
begin
write ('Введите число: ');
readln (n);
n:=abs (n);
while n>0 do
begin
if (n mod 10)>max then max:=n mod 10;
n:=n div 10;
end;
write ('Макс. цифра - ', max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Chohitto
26.01.2020 07:40
В таблице змейкой размещены пять английских слов которые связаны с темой урока. Слова в ответе записывайте по алфавиту английскими символами через один пробел информатика...
yliachedrina200
12.09.2020 23:18
Представьте развернутую запись чисел1)35742)413.02...
V369906
17.05.2021 17:24
решить задание по информатике 7 вариант...
ssmolden
18.01.2022 04:14
Задание 4. Выполните задание №7 из учебника. Напишите программу для решения задачи w10 из встроенного задачника. Обращайте вниманиена начальное и конечное положение Робота....
donga123
21.05.2023 03:02
0.05*9+0.05*18+0.05*27++0.05*90 информатика 9 класс...
kondan111
07.02.2020 03:42
Вхронологическом порядке перечень этапов развития информационной технологии: а) ручная, механическая, электронная, электрическая, компьютерная; б) каменная, механическая,...
Maria3111
07.02.2020 03:42
Вдень группа туристов покупает 10 буханок хлеба по а рублей,. 5 батонов по в тенге, 10 шт консервов по с рублей,. ведро картошки за д рублей на оставшиеся деньги они приобретают...
сашамо
07.06.2023 08:26
Повідомлення складене за до алфавіту з 64 символів, містить 4 сторінки, на кожні з яких по однаковій кількості рядків та кожен рядок містить по 64 символи. Знайти кількість...
даша3649
21.11.2020 21:00
Вывести значение наименьшего из трех параметров а, в, с если оно меньше или равно х и кратно 7, и частное наименьшего параметра и суммы двух оставшихся иначе.язык с.составить...
fbejgiwndkgk
21.11.2020 21:00
Вставте пропущене слово: «ефект анімації використовують для завершення відображення об’єкта, тобто зникнення об’єкта з екрана» вихід анімація демонстрація візуалізація питання...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n : integer;
max: byte;
begin
write ('Введите число: ');
readln (n);
n:=abs (n);
while n>0 do
begin
if (n mod 10)>max then max:=n mod 10;
n:=n div 10;
end;
write ('Макс. цифра - ', max);
end.