В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dashafomina94
dashafomina94
28.10.2021 18:06 •  Информатика

Pascal abc составьте программу которая имитирует скатывание мяча с горки. загрузите изображение горки из файла gorka.jpg . мяч изобразить в виде красного круга​

Показать ответ
Ответ:
kknopcka
kknopcka
04.01.2023 18:13

У каждого есть свои замыслы и идеи по поводу техники. Что на счёт меня, моя техника мечты - это домашний робот-компьютер со встроенным искусственным интеллектом. Он может служить отличным в домашних делах, хорошим собеседником и просто средством для развлечений. Проблема, к примеру, с математикой? Не нужно печатать и искать какой-то сайт с объяснениями. Можно спросить у робота. Он не только может решить, но и объяснит возможные ошибки. В таких же случаях его можно использовать, когда нужен совет или что-то подобное. А когда совсем скучно, можно попросить его сыграть с тобой в какую-нибудь игру. И робот сразу подключается через интернет к твоему игровому серверу и весёлое время препровождения гарантировано.

Объяснение:

Держи. Если я правильно поняла вопрос, конечно...

0,0(0 оценок)
Ответ:
madinakz1
madinakz1
07.02.2023 09:07

#include<iostream>

#include <cstdlib>

#include <math.h>

using namespace std;

int main(){

system("chcp 1251 > null");

int n = 0;

cout << "Задача 1.\n\tВведіть n: ";

cin >> n;

int i = 1;

while(i<=n){

     if(i%7==0) cout << i;

i++;    

   }

cout << "\n\n";

int a,b;

cout << "Задача 2.\n\tВведіть перше число діапазону: ";

cin >> a;

cout <<"\n\tВведіть друге число діапазону: ";

cin >> b;

double sum = 0;

double sr = 0;

int index = 0;

i = a;

while(i<=b){

  sum = sum+i;

  index++;

i++;

}

sr = sum / index;

cout << "\n\nСума: " << sum << "\nСереднє арифметичне: " << sr;

int x = 0;

int y = 0;

cout << "\n\nЗадача 3.\n\tВведіть x: ";

cin >> x;

cout << "\n\tВведіть y: ";

cin >> y;

cout << "Результат" << powl(x,y);

}

Вот, переделал задачу, под while. И кстати, отблагодарить ещё можно нажав кнопочку "Лучший ответ" ;-)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота