Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
vanchugovp02hjd
29.03.2022 09:42 •
Информатика
Pascal abc составить программу для нахождения s дано натуральное число n. найти сумму s=1- 1/5 + 1/9 - 1/+ (n-слагаемых) !
Показать ответ
Ответ:
alenka0810
07.10.2020 11:12
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
Writeln(Range(0,n-1).Select(i->1/(i.IsEven?4*i+1:-(4*i+1))).Sum)
end.
Пример
n= 13
0.876761945581588
для Pascal ABC (проверить негде, проект закрыт в 2004 году)
var
i,n,z:integer;
x,s:real;
begin
Write('n='); Read(n);
s:=0; z:=1;
for i:=0 to n-1 do begin
x:=1/(4*i+1);
s:=s+x*z;
z:=-z
end;
Writeln(s)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vwvwvwvwvwv
06.02.2023 20:30
Какое расширение имеют файлы...
akirienko2003
10.02.2023 16:04
Берілген тұжырымдамалардың ақиқат немесе жалған екенін анықтаңыз ( ) Иә Жоқ Блок-сызба - алгоритмді жазудың графиктік тәсілі Адам, компьютер, автомат – алгоритм орындаушысы...
marat5230
13.08.2021 20:02
перевести десятичные дроби в двоичную и восьмеричную системы счисления, оставив пять знаков в дробной части нового числа. а) 12,5; б) 312,54; в) 219,333. показать полное решение....
MarkTell
27.02.2022 07:27
Перевести целые числа из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы: а) 356; б) 514; в) 2018; г) 7654; д) 78. показать полное решение....
jutyra
14.03.2023 00:03
Перевести числа в десятичную систему счисления: а) а8 = 341; б) а6 = 341; в) а16 = 341; г) а5 = 34,1; д) а16 = е41а,12. показать полное решение....
maksatkuliyev4
20.03.2021 04:03
Составить блок схему линейного алгоритма: a=100; b=15. необходимо вычесть из большего числа меньшее и к полученной сумме прибавить 14 и результат умножить на 3....
1980а1980
18.03.2022 02:43
Из точки к плоскости проведены две наклонные. Известно, что разность длин наклонных равна 24см, а их проекции равны 5 и 35 см. Найдите расстояние от данной точки до плоскости....
artemlis1302200
05.07.2020 11:15
749.Проверьте, верны ли равенства:1) 18 1/3 (-6/11a-0,6b+0,3c)-4,5c=3/7 (-21a-23 1/3b+2 1/3c)-a-b; 2)-21 2/7 (-3,5a+1,4b+1,75c)+31,5b+39,75c=69,5a+3 1/3 (1,5a+0,6b+0,75c)...
zhenyaermakov
08.10.2020 03:02
Треугольнике ABC проведена прямая AD так, что ∠BAD=∠BCA. Найдите DB и DC, если AB=2 см, BC=4 см , КТО СМОЖЕТ РЕАЛЬНО....
MadamHlebushek11
03.12.2021 01:43
Етістікті бұйрық райда жіктеу Көмектесу...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
Writeln(Range(0,n-1).Select(i->1/(i.IsEven?4*i+1:-(4*i+1))).Sum)
end.
Пример
n= 13
0.876761945581588
для Pascal ABC (проверить негде, проект закрыт в 2004 году)
var
i,n,z:integer;
x,s:real;
begin
Write('n='); Read(n);
s:=0; z:=1;
for i:=0 to n-1 do begin
x:=1/(4*i+1);
s:=s+x*z;
z:=-z
end;
Writeln(s)
end.