В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dashalimonka2
dashalimonka2
01.01.2021 15:17 •  Информатика

Pascal abc посередине озера плавает плот, имеющий форму прямоугольника. стороны плота направлены вдоль параллелей и меридианов. введём систему координат, в которой ось ox направлена на восток, а ось оy – на север. пусть юго-западный угол плота имеет координаты (x1, y1), северо-восточный угол – координаты (x2, y2). пловец находится в точке с координатами (x, y). определите, к какой стороне плота (северной, южной, западной или восточной) или к какому углу плота (северо-западному, северо-восточному, юго-западному, юго-восточному) пловцу нужно плыть, чтобы как можно скорее добраться до плота. программа получает на вход шесть чисел в следующем порядке: x1, y1 (координаты юго-западного угла плота), x2, y2 (координаты северо-восточного угла плота), x, y (координаты пловца). все числа целые и по модулю не превосходят 100. гарантируется, что x1 < x2, y1 < y2, x ≠ x1, x ≠ x2, y ≠ y1, y ≠ y2, координаты пловца находятся вне плота. если пловцу следует плыть к северной стороне плота, программа должна вывести символ «n», к южной – символ «s», к западной – символ «w», к восточной – символ «e». если пловцу следует плыть к углу плота, нужно вывести одну из следующих строк: «nw», «ne», «sw», «se». пример входных и выходных данных ввод: -1 -2 5 3 -4 6 вывод: nw решение, правильно работающее для случаев, когда ответом является одна из сторон плота «n», «s», «w», «e»

Показать ответ
Ответ:
данчик321
данчик321
25.08.2020 21:25
//PascalABC.NET 3.2 сборка 1318

Var  x1,y1,x2,y2,x,y,x3,y3,x4,y4:integer;
begin
read(x1,y1,x2,y2,x,y);
x3:=x1;
y3:=y2;
x4:=x2;
y4:=y1;
if (x<x1) and (y<=y3) and (y>=y1) then writeln('W') else
if (x<x1) and (y>y3) then writeln('NW') else
if (x>=x1) and (x<=x2) and (y>y3) then writeln('N') else
if (x>x2) and (y>y3) then writeln('NE') else
if (x>x2) and (y<=y2) and (y>=y4) then writeln('E') else
if (x>x2) and (y<y4) then writeln('SE') else
if (x<=x4) and (x>=x1) and (y<y4) then writeln('S') else
if (x<x1) and (y<y1) then writeln('SW');
end.

Пример ввода:
-2 1 4 4 -3 5
Пример вывода:
NW
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота