Pascal abc напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. остальные элементы должны следовать далее в том же порядке. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести элементы полученного массива в одной строке, разделив их пробелами. примеры входные данные 6 6 2 1 5 3 4 выходные данные 1 2 3 6 5 4
a: array [1..10000] of integer;
i,j,k,m,n:integer;
begin
read(n);
for i := 1 to n do
read(a[i]);
for i := 1 to 3 do
begin
m := a[i];
k := i;
for j := i+1 to n do
if a[j] < m then
begin
m := a[j];
k := j
end;
for j := k downto i+1 do
a[j] := a[j-1];
a[i] := m
end;
for i := 1 to n do
write(a[i],' ')
end.