В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Daniela04102005
Daniela04102005
02.04.2021 16:14 •  Информатика

Pascal abc 1 составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат . 2 составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .

Показать ответ
Ответ:
marat2002671
marat2002671
09.07.2020 12:43
Первая программа ,если не нравится исправлю
Добавил вторую
0,0(0 оценок)
Ответ:
Ksysoeva20
Ksysoeva20
09.07.2020 12:43
1.
Program ZADACHA;
Uses crt;

var a: integer;

Begin clrscr;
      write('Введите целое число не равное нулю a = ');
      readln(a);
      writeln;
      if a<0 then
      Write('Число a отрицательное, результат = ', a*a)
     
      else
      Write('Число a положительное, результат = ', a/2);

End.

2.
Program CHETNOST;
Uses crt;

var a: integer;

Begin clrscr;
      write('Введите целое число a = ');
      readln(a);
      writeln;
      if (a mod 2) = 1 then
      Write('Да')
      else
      Write('Нет');

End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота