Pascal ABC: 1.Розробіть програми для виведення значення √х для парних чисел х у діапазоні від 2 до 10. 2.Визначення суми цілих додатних непарних чисел менше 30. За спам відправлю порушення.
Из Истории - 1) Наполеон Бонапарт - французский государственный деятель. 2) Христофор Колумб - открыл новый свет. Из Географии - 1) Россия - самое большое государство по площади. 2) В Китае больше всего населения. Из биологии - 1) Растения производят кислород. 2) У коровы есть вымя. Из математики - 1) 2+2=4 2) 6-2=4 Из Русского языка - 1) В русском алфавите - 32 буквы. 2) В сложном предложении 2 грамматические основы. Из Литературы - 1) А.С. Пушкин - русский поэт. 2) "Войну и Мир" Написал Л.Н. Толстой. Из информатики - 1) Информатика - наука о работе с информацией. 2) Вирт Никлаус - специалист в области информатки.
Составим программу вычисления суммы ряда чисел 5, 10, 15, …, 50 на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть s – сумма чисел ряда, которую надо найти, а i – порядковый номер чисел ряда. Начальное значение суммы s будет равным нулю. Так как чисел несколько, то будем использовать в программе оператор цикла с параметром for. По условию задачи числа суммируются, начиная с числа 5, с интервалом 4 числа, поэтому значение i в каждом цикле будем увеличивать на 4.
Программа может выглядеть так:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do begin
s:=s+i; {Вычисление суммы чисел}
i:=i+4; {Увеличение значения параметра i на 4}
end;
writeln ('s=',s) {Вывод результата суммы s}
end.
Можно решить данную задачу и вторым используя операцию mod:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do
if i mod 5=0 {Поиск чисел, кратных 5}
then s:=s+i; {Вычисление суммы чисел}
writeln ('s=',s); {Вывод результата суммы s}
end.
ответом будет s=275.
Составить программу нахождения значения функции у= 5х+х2, при х=50, 49, 48, 47, …, 40.
program zadacha;
uses crt;
var x,y,i:integer;
begin
for i:=50 downto 40 do begin y:=5*i+i*2; writeln ('y=',y); end;
1) Наполеон Бонапарт - французский государственный деятель.
2) Христофор Колумб - открыл новый свет.
Из Географии -
1) Россия - самое большое государство по площади.
2) В Китае больше всего населения.
Из биологии -
1) Растения производят кислород.
2) У коровы есть вымя.
Из математики -
1) 2+2=4
2) 6-2=4
Из Русского языка -
1) В русском алфавите - 32 буквы.
2) В сложном предложении 2 грамматические основы.
Из Литературы -
1) А.С. Пушкин - русский поэт.
2) "Войну и Мир" Написал Л.Н. Толстой.
Из информатики -
1) Информатика - наука о работе с информацией.
2) Вирт Никлаус - специалист в области информатки.
Составим программу вычисления суммы ряда чисел 5, 10, 15, …, 50 на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть s – сумма чисел ряда, которую надо найти, а i – порядковый номер чисел ряда. Начальное значение суммы s будет равным нулю. Так как чисел несколько, то будем использовать в программе оператор цикла с параметром for. По условию задачи числа суммируются, начиная с числа 5, с интервалом 4 числа, поэтому значение i в каждом цикле будем увеличивать на 4.
Программа может выглядеть так:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do begin
s:=s+i; {Вычисление суммы чисел}
i:=i+4; {Увеличение значения параметра i на 4}
end;
writeln ('s=',s) {Вывод результата суммы s}
end.
Можно решить данную задачу и вторым используя операцию mod:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do
if i mod 5=0 {Поиск чисел, кратных 5}
then s:=s+i; {Вычисление суммы чисел}
writeln ('s=',s); {Вывод результата суммы s}
end.
ответом будет s=275.
Составить программу нахождения значения функции у= 5х+х2, при х=50, 49, 48, 47, …, 40.
program zadacha;
uses crt;
var x,y,i:integer;
begin
for i:=50 downto 40 do begin y:=5*i+i*2; writeln ('y=',y); end;
writeln ('y=',y)
end.
Объяснение: