В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Rafaila111
Rafaila111
30.10.2020 09:35 •  Информатика

ответьте Написать программу, в которой создается массив из 10 элементов случайным образом, выводится на экран, находится произведение элементов массива, каждый элемент увеличивается в 10 раз

Показать ответ
Ответ:
Нифи2005
Нифи2005
11.04.2020 00:50

ө мен Бахтыбай Абылай хан атындағы қазақ ұлттық университетінің журналистика факультетін бітірген қазақ халқының саны жөнінен де бар білгені жөн бе әлде қоладан ба не истеп калайсындар мен Бахтыбай Абылай хан атындағы қазақ ұлттық университетінің журналистика факультетін бітірген қазақ халқының саны жөнінен де бар білгені жөн бе әлде қоладан ба не истеп калайсындар мен Бахтыбай Абылай хан атындағы қазақ ұлттық университетінің журналистика факультетін бітірген қазақ халқының саны жөнінен де бар білгені жөн бе әлде қоладан ба не истеп

0,0(0 оценок)
Ответ:
Мария017
Мария017
30.12.2020 10:34
Program Number;
var  x: integer; { введенное число }  n: byte := 0; { количество цифр в числе }  i, j: byte; { счетчики }  xi: array[1..5] of integer;{массив цифр, из которых состоит число}
begin  { Ввод исходного числа }  readln(x);  writeln;   x := abs(x); // рассматриваем модуль числа  { Разбиение числа на цифры }  while (x > 0) do  begin    n := n + 1; // увеличиваем количество цифр    xi[n] := x mod 10; // вычисляем цифру (остаток от деления на 10)    if xi[n] = 8 then // если встретилась 8,    begin      writeln('да'); // то число "бесконечное"      readln;      exit;          // выход из программы    end;    x := x div 10; // изменяем число (целое от деления на 10)  end;  { Поиск цифр, встречающихся больше одного раза}  for i := 1 to n - 1 do    for j := i + 1 to n do      if xi[i] = xi[j] then // если числа      begin        writeln('да'); // то число "бесконечное"        readln;        exit;  // выход из программы       end;  { Число не явлется "бесконечным" }  writeln('нет');end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота