В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vlad2217890
vlad2217890
03.07.2020 21:48 •  Информатика

ответь на вопросы по информатике. 1) Напишите программу, котораязапрашивает ввести несколько
слов с клавиатуры, а затем определяет длинусамого короткого
слова в строке.
2) Строковый метод isdigit() проверяет, состоит ли строка
только из цифр. Напишите программу, которая запрашивает с
ввода два целых числа и выводит их сумму. В случае некорректно-
го ввода программа не должна завершатьсошибкой, а должна
продолжать запрашивать числа. Обработчик исключений try-
except использовать нельзя.​

Показать ответ
Ответ:
kdortskaya55
kdortskaya55
27.03.2021 16:53

1) Ввод осуществляется в строку через пробел. В конце enter.

s = [i for i in input().split()]

min = len(s[0])

for i in s:

   if len(i) < min:

       min = len(i)

print(min)  

2) Осуществляешь ввод числа, если это не число, а символ, то программа будет снова запрашивать ввод до тех пор, пока в переменной не появится число.

a = input()

while not (a.isdigit()):

   a = input()  

b = input()

while not (b.isdigit()):

   b = input()  

print(int(a)+int(b))    

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота