В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
uychuuus
uychuuus
17.01.2021 16:20 •  Информатика

Определить функцию, составить программу на языке Pascal для вычисления следующего значения


Определить функцию, составить программу на языке Pascal для вычисления следующего значения

Показать ответ
Ответ:
9109160145davla
9109160145davla
07.04.2021 17:12
Procedure TForm1.Button1Click(Sender: TObject);
begin
    If FontDialog.Execute then
        RichEdit1.SelAttributes.Assign(FontDialog1.Font);
        RichEdit1.SetFocus;
    End;
end;

делфи у меня не установлены за совершенной ненадобностью, потому проверить возможности нет, но догадки показать могу.
 Не уверенна что RichEdit1.SelAttributes.Assign(FontDialog1.Font) выставляет шрифт, может там нужна кострукция типа
  RichEdit1.SelAttributes.Font := FontDialog1.Font
и конечно описка выделенная ранее, как на нее только компилятор не матерится
0,0(0 оценок)
Ответ:
annswi
annswi
25.08.2022 16:27

pascal

Объяснение:

procedure sortmas(a: array of integer);

var i, j, min, ind: integer;

begin

 for i := 0 to Length(a) - 2 do

 begin

   min := a[i]; ind := i;

   for j := i + 1 to Length(a) - 1 do

     if a[j] < min then

     begin

       min := a[j]; ind := j;

     end;

   a[ind] := a[i]; a[i] := min;

 end;

end;

var a: array of integer;

   n , i: integer;

begin

 WriteLn('Введите размер массива: '); Read(n);

 SetLength(a, n);

 Randomize;

 WriteLn('Содержимое массива:');

 for i := 0 to Length(a) - 1 do

 begin

   a[i] := random(100);

   Write(a[i], ', ');

 end;

 WriteLn;

 sortmas(a);

 WriteLn('Три минимальных элемента: ', a[0], ', ', a[1], ', ', a[2], ', ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота