В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Valerykh123
Valerykh123
09.05.2020 03:07 •  Информатика

Описание программы: написать программу,которая в одномерном массиве из 30 элементов заполненных вручную,оценками учеников по предмету,диапазон оценок от 2 до 5. входящие в эту программу: 1. подсчитать средний класса. 2. подсчитать кол-во двоечников, трое шнеков,хорошистов, отличников. хорошист 3.75-4-75. 3. подсчитать долю успевающих(всех у кого не 2) в паскалях

Показать ответ
Ответ:
Polinochka570
Polinochka570
09.10.2020 22:47

program n_1;

var a: array [1..30] of integer; n, m, k, l, i:integer; s: double;

begin

 n:=0; m:=0; n:=0; k:=0; l:=0;

 for i:=1 to 30 do begin

   read(a[i]);

   s:=s+a[i];

   if a[i]=2 then m:=m+1

   else if a[i]=3 then n:=n+1

   else if a[i]=4 then k:=k+1

   else if a[i]=5 then l:=l+1

 end;

 writeln('Средний класса: ', s/30);

 writeln('Количество двоечников: ', m);

 writeln('Количество троечников: ', n);

 writeln('Количество хорошистов: ', k);

 writeln('Количество отличников: ', l);

 writeln('Успеваемость класса: ', (30-m)/3*10, '%');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота