В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lisa1236
lisa1236
25.10.2022 11:23 •  Информатика

Одномерный массив содержит 100 элементов случайных целых чисел от 20 до 100. нужно написать программу вывода на экран этих чисел и найти сумму массива с 20 по 60 элемент.
программу нужно писать в паскале(pascalabc).

Показать ответ
Ответ:
anastassia7890
anastassia7890
10.10.2020 15:31

var a:array [1..100] of Integer;

i,s:Integer;

begin

write ('Массив ');

for i:=1 to 100 do

begin

a[i]:=random(81)+20;

write (a[i]:3);

if (i>=20) and (i<=60) then s:=s+a[i]

end;

writeln;

write ('Сумма ',s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота