В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Anna7225
Anna7225
21.06.2020 21:09 •  Информатика

очень Составьте программу, выясняющую, есть ли в двухмерном массиве C(P,Q) строка, элементы которой образуют геометрическую прогрессию

Показать ответ
Ответ:
Диана1еее
Диана1еее
27.01.2023 14:03

Для того, чтобы определить какое значение будет принимать переменная Х, после выполнения фрагмента исходной программы, пройдем по этой программе вручную следующим образом:

1) а: =4, b: = 5, с: = 3.

2) If a > b then x: = a + b

4 > 5 - не верно, значит переходим на следующий шаг программы после ключевого слова else:

3) else begin

a: = b + c = 5 + 3 = 8; получили, что значение a теперь равняется 8.

x:= а - 3 * b = 8 - 3 * 5 = 8 - 15 = -7.

4) Поскольку следующим идет команда end, значит программа завершает и получаем значение x: = -7.

Таким образом правильный вариант ответа - г).

Объяснение:

0,0(0 оценок)
Ответ:
dimon111222
dimon111222
12.02.2023 02:22

Проверенные ответы содержат информацию, которая заслуживает доверия. На «Знаниях» вы найдёте миллионы решений, отмеченных самими пользователями как лучшие, но только проверка ответа нашими экспертами даёт гарантию его правильности.

{Задача сделана на языке паскаль, при Оформление сделана как для студенческой задачи

Если есть во пиши в личку

Задача:Написать программу на языке программирования Pascal, которая вводит с клавиатуры 4 числа и выводит результат вычисления спо следующей схеме: "число1"−"число2"/"число3"+"число4"

Автор:

Дата:  }

 var  x1, x2, x3, x4: integer;

f:real;

begin

//Ввод

writeln('введите 1 число');

readln(x1);  

writeln('введите 2 число');

readln(x2);  

writeln('введите 3 число');

readln(x3);  

writeln('введите 4 число');

readln(x4); //решение

f:=(x1-x2)/(x3+x4);  

//вывод

writeln (f);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота