Очень Напишите программу, которая будет считывать четырехзначное число и выводить 1, если в нем ровно две одинаковые цифры, во всех остальных случаях программа выводит любое число.
Исполнители бывают двух типов: формальные (выполняют действия не понимая смысла работы) и неформальные (понимают то, что делают и могут изменить действия в алгоритме)
а) симфонический оркестр - неформальный исполнитель - могут вносить свои чуства в исполнение, понимают то, что делают музыканты.
б) ученик сам решает - неформальный испонитель
в) ученик списывает - формальный исполнитель
г) фармацевт - формальный (точное исполнение рецепта иначе может быть другой результат от лечения)
д) врач - неформальный исполнитель, тк зная возможные причины рассматривает разыне варианты, учитывая особенности данного человека
е) автомат - формальный исполнитель, вообще не понимает своих действий, выполняет заданную программу
ж) компьютер - формальный исполнитель - выполняет программу, созданную программистами.
2)Pascal
var s: string;
i, f, g: integer;
begin
writeln('Введите строку с угловыми скобками:');
readln(s);
f := pos('<', s);
if f = 0
then begin
write('Нет "<"');
if pos('>', s) = 0
then writeln('и ">"')
else writeln
end
else begin
g := 0;
for i := length(s) downto 1 do
if s[i] = '>'
then begin
g := i;
break
end;
if g = 0
then writeln('Нет ">"')
else if f > g
then writeln('">" левее "<"')
else begin
delete(s, f, g - f + 1);
writeln('Результат:');
writeln(s)
end
end
end.
Если гарантированно, что в тексте есть только по одному правильно расположенному символу "<" и ">", то совсем просто:
Pascal
var s: string;
begin
writeln('Введите строку с угловыми скобками:');
readln(s);
delete(s, pos('<', s), pos('>', s) - pos('<', s) + 1);
writeln('Результат:');
writeln(s)
end.
0
ответ:в правильный
Объяснение:
Исполнители бывают двух типов: формальные (выполняют действия не понимая смысла работы) и неформальные (понимают то, что делают и могут изменить действия в алгоритме)
а) симфонический оркестр - неформальный исполнитель - могут вносить свои чуства в исполнение, понимают то, что делают музыканты.
б) ученик сам решает - неформальный испонитель
в) ученик списывает - формальный исполнитель
г) фармацевт - формальный (точное исполнение рецепта иначе может быть другой результат от лечения)
д) врач - неформальный исполнитель, тк зная возможные причины рассматривает разыне варианты, учитывая особенности данного человека
е) автомат - формальный исполнитель, вообще не понимает своих действий, выполняет заданную программу
ж) компьютер - формальный исполнитель - выполняет программу, созданную программистами.