В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
fooorl
fooorl
09.04.2022 11:26 •  Информатика

ОЧЕНЬ НАДО Робинзон прожил на острове f дней. Написать программу, которая определяет сколько это лет недель и дней.

Показать ответ
Ответ:
06637381
06637381
27.04.2022 14:10

Программа:
Pascal:

var

 f, years, weeks, days: integer;

begin

 readln(f);

 years := f div 365;

 weeks := (f - years * 365) div 7;

 days := f - years * 365 - weeks * 7;

 writeln(f, ' дней - это ', years, ' лет, ', weeks, ' недель, ', days, ' дней.');

end.

Объяснение:

В начале регистрируются переменные f, years, weeks, days. Далее - вводится число f (дней). Число полных лет - результат целочисленного деления f на 365. Число полных недель - результат целочисленного деления оставшегося количества дней на 7. Число дней - оставшиеся количество дней после определения years и weeks. В конце - вывод этих значений.

Результат:

1000

1000 дней - это 2 лет, 38 недель, 4 дней.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота