В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
мишка2283
мишка2283
05.11.2022 02:38 •  Информатика

Объясните и напишите код программы на языке с++1. напишите программу, которая сравнивает количество перестановок при сортировке одного и того же массива разными . 2. проведите эксперименты для возрастающей последовательности (уже отсортированной), убывающей (отсортированной в обратном порядке) и случайной.

Показать ответ
Ответ:
llovepet20
llovepet20
22.11.2022 20:44

// Программа выводит по 10 раз имя и фамилию тремя разными циклами for while

// repeat until

 

Program LoopName;

Uses Crt;

var name,s_name:string;

       i:integer;

begin

    clrscr;

    write('Введите имя: ');

    readln(name);

   write('Введите фамилию: ');

   readln(s_name);

   writeln('Цикл For');

 

   for i:=1 to 10 do writeln(name,'  ',s_name );

 

   writeln;

  writeln('Цикл while'); 

    i:=1;

   while (i<=10) do

      begin  

          writeln(name,'  ',s_name );

           i:=i+1;

       end;  

 

   writeln;  

   writeln('Цикл repeat until');

         

    i:=0; 

    repeat

          writeln(name,'  ',s_name );

           i:=i+1;

     until(i=10); 

   readkey; 

 end.

 

 

 

 

0,0(0 оценок)
Ответ:
vitoszemko200
vitoszemko200
22.11.2022 20:44

Ниже жирным шрифтом приведен код программы на Паскале. В фигурных скобках обычным шрифтом - комментарии. Можно их оставить - компилятор не сможет их прочитать и программа все равно будет работать.

 

 

program printname;
var first_name, family_name : string;
i : byte;

begin
write('Введи свое имя: ');
readln(first_name); {считываем имя в переменную first_name}
write('Введи свою фамилию: ');
readln(family_name); {считываем фамилию в переменную family_name}
for i := 1 to 10 do writeln(family_name, ' ', first_name); {В цикле for со счетчиком i изменяющимся от 1 до 10 печатаем строки с фамилией и именем через пробел}
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота