В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Елленаа
Елленаа
07.11.2021 11:51 •  Информатика

Обращаюсь к информатикам!
Составить программу в Паскале для обработки одномерного массива из 15 чисел. Значения элементов массива задать с клавиатуры самостоятельно. Найти наименьший элемент массива и его номер.
Заранее огромное

Показать ответ
Ответ:
LilyBlackk
LilyBlackk
12.10.2020 22:24

Pascal ABC

Код:

var

  a: array [1..15] of integer;

  i, min: integer;

begin

    //заполнение массива

    for i := 1 to 15 do

        readln(a[i]);

    //поиск минимума

    min := 1;

    for i := 1 to 15 do

        if a[min] > a[i] then min := i;

    //вывод минимального и его номера

    writeln('Минимум: ', a[min], ' Номер: ', min);

end.

Тесты:

Ввод:

4 5 7 8 9 2 1 3 4 5 8 7 6 8 2

Вывод:

Минимум: 1 Номер: 7

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота