В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
timkaserka
timkaserka
16.04.2022 02:10 •  Информатика

Обработка двумерных массивов. алгоритм вычисления среднего значения массива, пример программы

Показать ответ
Ответ:
алінка20
алінка20
28.09.2020 16:18
Пример, ненужное уберешь

const
    handsfree = true;

var
    a: array[1..100, 1..100] of real;
    max, min: real;
    sum, product: real;
    i, j, m, n, k: integer;

begin
    {ввод матрицы}
    if handsfree then begin
        n := random(20) + 2;
        m := random(20) + 2;
    end
    else begin
        write('n, m =');
        readln(n, m);
    end;
    
    writeln('Данные матрицы:');
    for i := 1 to m do
    begin
        for j := 1 to n do
            if handsfree then begin
                a[i, j] := random(100) - 50;
                write(a[i, j]:4, ' ')
            end
            else
                read(a[i, j]);
        writeln;
    end;
    
    {минимумы и максимумы}
    max := a[1, 1];
    min := a[1, 1];
    for i := 1 to m do
        for j := 1 to n do
        begin
            if max < a[i, j] then max := a[i, j];
            if min > a[i, j] then min := a[i, j];
        end;
    writeln('max = ', max);
    writeln('min = ', min);
    
    {сумма, произведение, пр. агригаты}
    sum := 0;
    product := 1;
    for i := 1 to m do
        for j := 1 to n do
            if a[i, j] <> 0 then {если нужен фильтр}
            begin
                sum := sum + a[i, j];
                product := product * a[i, j];
                k := k + 1;
            end;
    writeln('sum = ', sum);
    writeln('product = ', product);
    writeln('average = ', sum / (n * m));
    writeln('average (selected) = ', sum / k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота