В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
frogRICH
frogRICH
11.08.2021 04:15 •  Информатика

Нужно вытянуть ! напишите процедуру ввода n элементов массива из файла. отсортируйте по невозрастанию методом простого обмена. (паскаль)

Показать ответ
Ответ:
вирона1
вирона1
02.10.2020 05:05
Var  i,j,n,k: integer; 
 a: array [1..100] of integer;
begin
assign (input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
readln (n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do 
for j:=1 to n-i do
 if a[j+1]>a[j]
then begin k:=a[j]; a[j]:=a[j+1]; a[j+1]:=k; end;
for i:=1 to n do
write (a[i],' ');
end.

Входные данные писать в файл input.txt в формате:
n
a[i] a[i+1] a[i+2]...a[n].
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота