Нужно выполнить три любых задания(написать полноценную программу на паскале)
Используя оператор условного перехода, напишите программу, которая:
1) классифицирует компьютерную сеть. Программа запрашивает у пользователя число компьютеров в сети и в зависимости от введенного количества выводит класс сети (если число ЭВМ меньше 256 - то это сеть класса С, от 256 до 65535 - сеть класса В, свыше 65535 - сеть класса А);
2) запрашивает у пользователя номер одного из весенних месяцев, и выводит количество дней в этом месяце. Программа должна проверять, является ли введенный месяц весенним;
3) выводит на экран приглашение: «Который час?», вводит с клавиатуры число X, имеющее смысл времени суток, и печатает слова «Доброе утро», «Добрый вечер», «Добрый день» в зависимости от введенного времени. Программа должна реагировать на ввод неправильного времени: меньше 0 или больше 24;
4) запрашивает с клавиатуры у пользователя размер хищений (р.), определяет и выводит на экран масштаб в соответствии с принятой классификацией (например, если размер хищений меньше 100 р. - «мелкий», от 100 до 1000 - «крупный», свыше 1000 - «особо крупный»);
5) выводит на экран приглашение: «Введите месяц», вводит с клавиатуры число X, имеющее смысл месяца, и печатает слова «Зима», «Весна», «Лето», «Осень» в зависимости от введенного месяца. Программа должна реагировать на ввод неправильного месяца: меньше 1 или больше 12;
6) запрашивает у пользователя номер одного из летних месяцев, и выводит количество дней в этом месяце. Программа должна проверять, является ли введенный месяц летним;
7) вводит с клавиатуры три числа и выводит на экран максимальное из них;
8) выводит на экран приглашение: «Введите день недели», вводит с клавиатуры число X, имеющее смысл дня недели, и печатает слова «Рабочий день», «Короткий день», «Выходной» в зависимости от введенного дня. Программа должна реагировать на ввод неправильного дня недели: меньше 1 или больше 7;
9) запрашивает у пользователя номер одного из осенних месяцев, и выводит количество дней в этом месяце. Программа должна проверять, является ли введенный месяц осенним;
10) запрашивает с клавиатуры два целых числа, их сумму и произведение и выводит на экран сообщение о правильности сделанных пользователем вычислений;
11) вводит с клавиатуры три числа и выводит на экран минимальное из них;
12) запрашивает с клавиатуры два целых числа, их разность и частное (результат деления) и выводит на экран сообщение о правильности сделанных пользователем вычислений;
13) запрашивает у пользователя номер одного из зимних месяцев, и выводит количество дней в этом месяце. Программа должна проверять, является ли введенный месяц зимним;
14) вводит с клавиатуры число X. Если X меньше 10, то вычисляет и выводит на экран квадрат числа X, а если больше или равно, то вводит новое число Y, а затем вычисляет и выводит на экран значение суммы X и Y;
15) запрашивает с клавиатуры три произвольных числа и выводит на экран сообщение о том, сколько из них отрицательных, положительных и нулевых.
Представлю 3 программы два с массивом и один без массива
1)var a:array [1..10] of integer;
i,n,k5,k2:integer;
begin
writeln('введите количество экзаменов');
read(n);
for i:=1 to n do begin
writeln('введите оценку за экзамен');
readln(a[i]);
end;
for i:=1 to n do begin
if a[i]=5 then k5:=k5+1;
if a[i]=2 then k2:=k2+1;
end;
writeln('количество пятерок ',k5);
writeln('количество двоек ',k2);
end.
2)var a:array [1..10] of integer;
i,n,k5,k2:integer;
begin
writeln('введите количество экзаменов');
read(n);
for i:=1 to n do begin
writeln('введите оценку за экзамен');
readln(a[i]);
if a[i]=5 then k5:=k5+1;
if a[i]=2 then k2:=k2+1;
end;
writeln('количество пятерок ',k5);
writeln('количество двоек ',k2);
end.
3)var a,i,n,k5,k2:integer;
begin
writeln('введите количество экзаменов');
read(n);
if n<=10 then begin
for i:=1 to n do begin
writeln('введите оценку за экзамен');
readln(a);
if a=5 then k5:=k5+1;
if a=2 then k2:=k2+1;
end;
writeln('количество пятерок ',k5);
writeln('количество двоек ',k2);
end;
end.
1) a x a = a² ⇒ b; b x a = a³ ⇒ результат
2) a x a = a² ⇒ b; b x b = a⁴ ⇒ c; c x c = a⁸ ⇒ c; c x b = a¹⁰ ⇒ результат
Программа на языке PascalABC.Net
var
a,b,c,y:real;
begin
Write('Введите число: '); Read(a);
b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
c:=b*b; c:=c*c; y:=b*c;
Writeln('Десятая степень числа равна ',y)
end.
Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024
Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574