нужно составить программы для Python решая задачи 2. Даны три различных числа A, B, C. Выведите на экран значение среднего из них.
4. Даны три числа, два из которых одинаковые. Выведите на экран значение третьего числа, отличного от двух других.
6. Написать программу, которая по последней цифре числа определяет последнюю цифру её квадрата (цифра, на которую заканчивается квадрат числа, зависит только от последней цифры самого числа)
8. На вход программе подается 3 числа - значение RGB модели некоторого цвета. Известно, что все числа либо равны 255 либо 0. Напишите название цвета, модель которого вам задается.
{Free Pascal Compiler version 3.0.4+dfsg-23 [2019/11/25] for x86_64}
{Copyright (c) 1993-2017 by Florian Klaempfl and others}
{Target OS: Linux for x86-64}
program test;
Uses Math;
const N = 15;
var
A : array[1..N] of integer;
i, mx, k : integer;
begin
Randomize;
{Генерация и печать массива}
for i := 1 to N do begin
A[i] := Random(50);
write(A[i], ' ');
if A[i] mod 2 = 1 then mx := A[i]
end;
writeln;
for i := 1 to N do
if A[i] mod 2 = 1 then
if A[i] < mx then begin
mx := A[i];
k := i
end;
writeln('Число - ', mx, ', позиция - ', k);
end.
Результат выполнения программы:
ответ: В реальной жизни выполнение всяких действий связано с расходом различных ресурсов: материалов, энергии и времени. Даже производя какие-либо записи, мы расходуем ресурсы (например, бумагу, чернила и время). Еще недавно некоторые задачи нельзя было решить из-за слишком большого числа необходимых для этого операций и слишком малой скорости их выполнения. Появление электронных вычислительных машин сделало такие задачи разрешимыми. Алгоритму в интуитивном смысле в книге противопоставляется алгоритм в математическом, или формальном смысле. В последнем случае считается, что понятие определено методами, принятыми в математике, и основывается либо на других понятиях, имеющих математическое определение, либо на первоначальных, описанных настолько четко, что их свойства могут быть приняты за аксиомы новой теории. Теорию алгоритмов, которой посвящена эта книга, мы называем содержательной в том смысле, что именно алгоритмы как таковые во всем их разнообразии являются ее предметом.
Объяснение: