В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Alinыch11
Alinыch11
18.08.2022 02:51 •  Информатика

Нужно составить программу в турбо паскаль, которая находит минимальный элемент в массиве и ставит его на первое место, при этом все остальные элементы сдвигаются. вывести на экран новый массив.

Показать ответ
Ответ:
elsafrozen24
elsafrozen24
03.10.2020 08:36
Const n = 10;
var a:array[1..n]of integer;
  min,imin,i,oldmin:integer;
begin
  //Заполнение массива значениями в диапазоне
  //от -100 до 100
  //и одновременно находим минимальный элемент элемент
  min:=100;
  for i:=1 to n do begin
    a[i]:=random(201)-100;
    if a[i]<= min then
    begin
      min:=a[i];
      imin:=i;//Запомним index минимального
    end;
    write(a[i]:5);
  end;
  writeln;
 
  //В цикле сдвигаем элементы массива
  //до индекса минимального включительно на
  //одну позицию вправо
  for i:=imin downto 2 do
    a[i]:=a[i-1];
    a[1]:=min;
  //вывод элементов массива
  for i:=1 to n do write(a[i]:5);
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота