В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Gusuanskiy
Gusuanskiy
24.02.2021 01:03 •  Информатика

Нужно составить программу pascal, в которой вводятся интервалы двух отрезков и число х. программа должна определять какому отрезку принадлежит это число. без использования and и or​

Показать ответ
Ответ:
MeilisS
MeilisS
05.05.2020 14:59

Объяснение:

program kek;

var

 l1, r1, l2, r2, x: Integer;

begin

 read(l1, r1, l2, r2, x);

 if ((x-l1)*(r1-x) >= 0) then writeln('Первый отрезок.');

 if ((x-l2)*(r2-x) >= 0) then writeln('Второй отрезок.');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота