Нужно составить программу(ну как всегда varbegan ну и т.д.) дана дробь a/b. требуется ее сократить. то есть записать это же число в виде c/d, где c — целое число, d — натуральное число и d минимальное возможное.
var i,a,b,a1:integer; begin readln(a,b); a1:=a; for i:=1 to a1 do begin if (a mod i=0) and (b mod i=0) then begin a:=a div i; b:=b div i; end; end; writeln('c=',a,' d=',b); end.
var i,a,b,a1:integer;
begin
readln(a,b);
a1:=a;
for i:=1 to a1 do begin
if (a mod i=0) and (b mod i=0) then begin
a:=a div i;
b:=b div i;
end;
end;
writeln('c=',a,' d=',b);
end.