Нужно составить программу на нахождения значения выражения
у= 2.5* cos a+ x/(d+8)
А. Интерфейс необходимо создать понятным для пользователя.
В. Необходимо описать действия любых двух компонентов программы:
Компонент Действия
С. Написать код программы в тетради
ну ответьте по-братски
вы же хорошие человеки
В примере ответы не соответствуют заданию: ищется самая большая цифра а не маленькая, а по условию должна искаться самая маленькая. Написал код, который соответствует именно заданию:
Объяснение:
var
n, k, min, colmin, i: integer;
begin
repeat
Write('Введите число: ');
Readln(n);
until (n>=10000) and (n<=99999);
k := n;
min := k mod 10;
k := k div 10;
for i := 1 to 4 do
begin
if (k mod 10 < min) then min := k mod 10;
k := k div 10;
end;
k := n;
for i := 1 to 5 do
begin
if (k mod 10 = min) then inc(colmin);
k := k div 10;
end;
WriteLn(min, ' ', colmin);
end.
унарный * - модификатор указателя, например, когда мы обявляем функцию void a(TypeName b); подоразумевается, что функция принимает переменную b типа данных TypeName, а если же напишем void a(TypeName* b); то подоразумеваем, что функция принимает указатель б типа данных TypeName
ответ: 4
П.с. задача не корректна, поскольку в вариантах ответа записаны не обьявления функции, а ее вызов. А если надо передать обыкновенную переменную по указателю, тогда используем модификатор ссылки &
void func(TypeName* a);
//...
TypeName a0 = 0;
TypeName* a1 = &a0;
func(&a0);
func(a1);