В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
orlovski155555
orlovski155555
24.02.2021 02:18 •  Информатика

Нужно : составить программу, которая вычисляет сколько будет на вкладе через заданное количество лет (любое)

Показать ответ
Ответ:
дэвттвс
дэвттвс
14.09.2022 03:51
Uses crt;
var r: array [1..10] of integer;
      nev, n, min,i, zap:integer;
begin
   clrscr;
   write('Введите возраст невесты: '); readln(nev);
   write('Введите число женихов: '); readln(n);
   if n<2 then
   for i:=1 to n do
   begin
   write('Введите возраст ',i,'-го жениха: '); readln(r[i]);
   end;

   i:=0; zap:=0;
   while (zap=0) and (i<=n) do begin  
     i:=i+1;
     min:=nev-r[i];
     if min>0 then zap:=i;
   end;
   if i<>n then
   begin
     for i:=zap to n do
     begin
        if min>(nev-r[i]) then
        begin
           zap:=i;
           min:=nev-r[i];
         end;
     end;
     writeln('Самый молодой жених старше невесты в возрасте ',r[zap], ' лет. Разница в возрасте составляет ', min, ' лет.');
     writeln ('По счету это ',i,'-ый жених');
   end
   else writeln('Среди женихов нет подходящего для нашей невесты.');
  end;
  else writeln('Число женихов должно быть более 2!');
end.
     
0,0(0 оценок)
Ответ:
panda2438
panda2438
23.03.2023 15:56
Бесконечность – не предел! Этот девиз из известного высказывания Стива Джобса как нельзя лучше отражает происходящее в настоящее время проникновение прогрессивных технологий в жизнь человека. Современная физика предполагает, что в основе окружающей человека реальности лежит бесконечность. Перед бесконечностью все равны и кибернетический суперинтеллект будущего и человек с его недостатками, всем есть экологическая ниша для жизни. Будущее принадлежит не человеку и не роботу, а своеобразному кентавру – человеко-машинному комплексу. Из выше сказанного тривиально следует команду назвать: Кентавры.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота