Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
тигр186
24.10.2021 22:30 •
Информатика
Нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями
Показать ответ
Ответ:
сергейщепетинов
02.08.2020 16:51
Не понял смысл задачи.
Написал, вывод номера элементов равных 0.
0,0
(0 оценок)
Ответ:
45r77yf
02.08.2020 16:51
#include <stdio.h>#include<stdlib.h>
int main(void){ int mas[16]; //массив со случайными числами int i; //счетчик
//заполнение массива случайными числами for(i=0; i<16; i++) mas[i] = -20+rand()%20; printf("ishodny massiv"); for(i=0;i<16;i++) printf("%d,",mas[i]); printf("\n");
printf("nomera elementov massiva ravnih nulu"); for(i=0;i<16;i++) if (mas[i]==0) printf("%d",i+1);
return 0;}
0,0
(0 оценок)
Популярные вопросы: Информатика
1992svetlana
17.07.2020 15:00
ТЕКСТ ЗАДАНИЯЗАГРУЗКА ФАЙЛОВ...
veronikatulene
13.09.2022 16:28
Составить блок-схему , программу трассировачную таблицу для следующей задачи:найти сумму всех чисел , которые оканчиваются на цифру 3 и 7 в диапазоне от 22 до 27 . Повторите , сор...
9955Х
07.01.2021 12:11
Паскаль 10 класс . много чего ещё не понимаю 1) определите сумму четных чисел до числа n введённые с клавиатуры n=10 s=2+4+6+8+10=30 2) составить программу которая вводит с клавиатуры...
ArtLeg
07.01.2021 12:11
Впакете лежат фрукты. все кроме двух персиков, дух яблок, двух груш. сколько фруктов в пакете ии каких?...
Albert116
07.01.2021 12:11
Определите значение переменной а после выполнения данного алгоритма b: =4 a: =3 b: =7-2*a-b a: =b/3-a...
beka1098
05.10.2022 13:46
Даны числа a и b. вывести их произведение a × b. входные данные: в первой строке входного потока содержится число a, во второй – число b (0 = a = 10100), (1 = b = 10000). выходные...
дитанатор
05.10.2022 13:46
Ввелокроссе участвуют 128 спортсменов. специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая его номер цепочкой из нулей и единиц минимальной...
Maksimka087
07.06.2021 06:48
Для кодирования букв о, к, м, л решили использовать двоичное представление чисел 0 , 1 , 2 и 3 соответственно (с сохранением одного незначащего нуля в случае одноразрядным представления)...
Arina0903
07.06.2021 06:48
1. написать программу, в которой пользователь задает три стороны треугольника и которая выводит слово true, если треугольник равносторонний, и false, если не равносторонний. 2. написать...
Daleton
14.09.2020 03:32
Какое логическое выражение эквивалентно выражению ¬(¬a ^ b) ^ ¬c? 1) (a ^ b) ^ ¬c 2) (a v b) v c 3) (a ^ ¬b) v ¬c 4) (a v ¬b) ^ ¬c для какого из значений числа y высказывание (y 5)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Написал, вывод номера элементов равных 0.
int main(void){ int mas[16]; //массив со случайными числами int i; //счетчик
//заполнение массива случайными числами for(i=0; i<16; i++) mas[i] = -20+rand()%20; printf("ishodny massiv"); for(i=0;i<16;i++) printf("%d,",mas[i]); printf("\n");
printf("nomera elementov massiva ravnih nulu"); for(i=0;i<16;i++) if (mas[i]==0) printf("%d",i+1);
return 0;}