нужно составить программу для решения :
известно,что 31 января 2011 года было понедельником. известно, что 31 января 2011 года приходится на понедельник. какие значения должны быть присвоены переменной у в алгоритме, определяющем день недели для любого числа (chislo) января 2011 года?
chislo : = chislo mod 7
если chislo=3 то y: = "
если chislo=4 то y: = "
если chislo=5 то y: = "
если chislo=6 то y: = "
если chislo=0 то y: = "
если chislo=1 то y: = "
если chislo=2 то y: = "
2 - меньше информации
3 - глобус, макет здания, муляж яблока, манекен
4 - рисунок, фотография
5 - знаковой
6 - смешанной
7 - автомобиль — техническое описание автомобиля, город — путеводитель по городу
8 - существенные признаки объекта-оригинала
9 - разные модели объекта
10 - физическая карта, график зависимости расстояния от времени, схема узора для вязания крючком, схема метро
11 - словесное описание, формула
12 - знаковой
13 - смешанной
14 - болт — чертеж болта, мелодия — нотная запись мелодии
begin
var n:=ReadInteger('Число элементов массива=');
var a:=ArrRandom(n,-25,25);
Write('Исходный массив: '); a.Println;
var k:=a.Where(x->sqr(x)>sqr(a[0])).Count;
if k>0 then Writeln
('Найдено ',k,' элементов, квадрат которых больше квадрата первого')
else Writeln
('Нет ни одного элемента, квадрат которого больше квадрата первого')
end.
Тестовое решение:
Число элементов массива=15
Исходный массив: 11 12 -11 -3 -16 -22 22 4 -4 -1 -16 -9 -19 4 16
Найдено 7 элементов, квадрат которых больше квадрата первого