В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ksenia2351
Ksenia2351
17.03.2022 03:28 •  Информатика

Нужно составить программу через процедуру в паскаль : каждая бактерия делится на две в течение одной минуты. в начальный момент имеется одна бактерия. составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени. через procedure : (

Показать ответ
Ответ:
кирилл2122
кирилл2122
23.09.2020 12:48
Procedure copy_bacterium(time:integer);
var
i, bacterium:integer;

    begin
    bacterium:= 1;
    for i:=1 to time do
        bacterium:= bacterium * 2;
    writeln(bacterium);
    end;
var
n:integer;
begin
readln(n);
copy_bacterium(n);
end.    
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота