В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
565765g
565765g
12.12.2021 06:12 •  Информатика

Нужно сделать в паскаль авс самолет летит из пункта а в пункт б со средней скоростью v. составить программу для нахождения времени полёта t1, если есть встречный ветер, скорость которого v1, и времени t2, если ветра нет. расстояние между пунктами a и б считать известным и равным s.

Показать ответ
Ответ:
LARINA259
LARINA259
24.05.2020 23:02

var S, V, V1: real;

     t1, t2: real;

     b: boolean;

begin

  b:=false;

  repeat

    writeln('Введите расстояние между пунктами А и Б');

    readln(S);

    if S<0 then

      begin

        writeln('Отрицательное расстояние. Повторите ввод');

        continue;

      end;

    writeln('Введите среднюю скорость самолета');

    readln(V);

    if V<0 then 

      begin

        writeln('Отрицательная скорость. Повторите ввод');

        continue;

      end;

    writeln('Введите скорость встречного ветра');

    readln(V1);//Если ветра нет нужно ввести 0

    if V1<0 then

      begin

        writeln('Отрицательная скорость. Повторите ввод');

        continue;

      end;

    b:=true;

  until b = true;

  if V1>0

  then

    begin

      t2:=S/V;

      writeln('Время полета: ', t2);

    end

  else

    begin

      t1:=(V-V1)/S;

      writeln('Время полета: ', t1);

    end;

end.

 

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота