В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Yournick
Yournick
14.09.2021 19:59 •  Информатика

нужно очень На языке Паскаль Напишите программу наименьшего общего кратного следующих четырех чисел: 36, 54, 18 и 15, используя процедуру вычисления наибольшего общего делителя двух чисел.
Если можно, то с объяснением

Показать ответ
Ответ:
мадина488
мадина488
06.02.2021 14:40

// НОД(a,b)*НОК(a,b)=a*b

procedure nod(x,y: integer; var n: integer);

begin

    repeat

        if x>y then x:=x mod y

        else y:=y mod x;

    until (x=0)or(y=0);

n:=x+y;

end;

var a,b,c,d,e,n: integer;

begin

readln(a,b,c,d);

nod(a,b,n);

e:=a*b div n;

nod(c,e,n);

e:=c*e div n;

nod(d,e,n);

Writeln('НОК = ',d*e div n);

end.

Объяснение:

Пример:

36 54 18 15

НОК = 540

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота