В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
looolll2k17
looolll2k17
05.02.2020 02:52 •  Информатика

Нужно нарисовать примерно такой замок в паскале и скинуть код

Показать ответ
Ответ:
Умник333331
Умник333331
13.02.2021 20:23
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.

var
  n,s,t,i:integer;
begin
  Write('Укажите количество данных: ');
  Read(n);
  Writeln('Теперь вводите данные');
  s:=0;
  for i:=1 to n do
    begin
    Read(t);
    s:=s+t
    end;
  Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.

Пример решения

Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4
0,0(0 оценок)
Ответ:
Shvabra335
Shvabra335
19.03.2021 17:07

Логическая функция - взаимосвязь между различными высказываниями, которые мы называем аргументами функции. Похожа на обычную числовую функцию, только вместо чисел - высказывания.

Логическое выражение - это конструкция в языке программирования, которая при выполнении даёт результат "истина" или "ложь".

Общее этих понятий в том, что они используются, например, в программе Excel, а также они связаны скорее не с числами, а с утверждениями. А разница в том, что первое - это зависимость, а второе - конструкция.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота