В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Аделина2605
Аделина2605
28.06.2021 02:02 •  Информатика

НУЖНО Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведите «YES», иначе выведите «N0».
Программа получает на вход число проехавших автомобилей N (1 < N < 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300.Программа должна сначала вывести максимальную скорость, затем YES или NO.


НУЖНО Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическ

Показать ответ
Ответ:
eynulla
eynulla
14.01.2021 21:26

# include <iostream>

int main() {

short n;

std::cin >> n;

bool minSpeed = false;

short maxSpeed = INT8_MIN;

short buf;

for (short j = 0; j < n; j++) {

 std::cin >> buf;

 if (not minSpeed and buf < 30) minSpeed = true;

 if (buf > maxSpeed) maxSpeed = buf;

}

std::cout << maxSpeed << "\n" << ((minSpeed) ? "YES" : "NO");

};

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота