В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kolodenkoa444
kolodenkoa444
08.12.2022 02:03 •  Информатика

Нужно написать программу в языке Паскаль. Расстояние d между точками А(х1 у1) и В(х2 у2) вычисляется по формуле d=√(x2-x1)^2+(y2-y1)^2 Вычислите АВ

Показать ответ
Ответ:
ГЕОГАФИЯ
ГЕОГАФИЯ
02.06.2021 23:28
program massiv4;
uses crt;
var a, b, c:integer;
begin
clrscr;
randomize;
a:=random(3)+2;
b:=random(35)+10; 
c:=a*b*100;
writeln(c);
readln;
end.

вариант 2: показывает более плавную кривую распределения символов A по странице, поскольку генерирует случайное значение встречаемости символа в каждой новой строке:

program massiv4;
uses crt;
var i, a, b, c:integer;
begin
for i := 0 to 99 do
begin
randomize; 
b:=random(35)+10; 
for i := 1 to b do
begin
randomize; 
a:=random(3)+2; 
for i := 1 to a do
begin
c:=c+a*b;
end;
end;
end;
writeln(c); 
readln;
end.
0,0(0 оценок)
Ответ:
КРЕНДЕЛЬ228
КРЕНДЕЛЬ228
27.04.2023 19:35
1)
var   k,a,i,n : integer;
   t : Text;
    begin 
 readln (k);
 n := 0;
  Assign (t,'test.txt');
  Reset(t);
  i := 1;
   while not Eof(t) do
    begin   
 read (t,a);   
   if a = k then 
     n := i;   
   i := i +1;  
   end; 
  Close (t); 
 writeln (n);
 end.

2)

 var 
 t,t1,t2 : Text;
  i : integer;
  a : real;
 begin
  Assign (t,'text.txt'); 
 Reset (t);
  Assign (t1,'r1.txt');
  rewrite (t1); 
 Assign (t2,'r2.txt'); 
 rewrite (t2); 
   i := 1; 
   while not Eof(t)
 do  
 begin 
   read (t,a); 
    if i mod 2 = 1 then
      write (t1,a:3:3,' ') 
      else 
       write (t2,a:3:3,' ');
    i:= i +1;  
    end;  
  Close (t); 
 Close (t1); 
 Close (t2);
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота