В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Dimoo9n
Dimoo9n
27.01.2023 22:37 •  Информатика

Нужно написать программу в с# или исправить мой код, мой код ниже за , нужно что бы программа была рабочая при изменении начальных параметров что бы менялись ответы
using System;
namespace ConsoleApp3
{
class Program
{
public static void Main(string[] args)
{
int n = 3;
double s = 1;
for (int i = 1; i <= n; i++)
{
s = s * (1 + 1 / (i * i));
}
Console.WriteLine("S={0:f3}", s);
Console.ReadKey();
}
}
}


Нужно написать программу в с# или исправить мой код, мой код ниже за , нужно что бы программа была р

Показать ответ
Ответ:
ProninaSneshana
ProninaSneshana
02.03.2022 18:40

Відповідь:

using System;

namespace ConsoleApp3

{

class Program

{

public static void Main(string[] args)

{

int n = Convert.ToInt32(Console.ReadLine());

double s = 0;

for (int i = 1; i <= n; i++)

{

s += s * (1 + 1 / (i * i));

}

Console.WriteLine("S={0:f3}", s);

Console.ReadKey();

}

}

}

0,0(0 оценок)
Ответ:
kurotetsu666
kurotetsu666
02.03.2022 18:40

// В вашем коде сразу бросается в глаза деление 1 / (i * i). Тут 1, i -- это int => i*i тоже int. В итоге делим int на int. И результат получаем соответствующий. Обязательно узнайте про целочисленное деление

using System;

namespace ConsoleApp1

{

   internal class Program

   {

       private static void Main()

       {

           Console.Write("Enter n: ");

           int n = int.Parse(Console.ReadLine());

           if (n < 1)

           {

               Console.WriteLine("incorrect value");

               return;

           }

           double res = 1;

           for (int i = 1; i <= n; i++)

               res *= 1 + 1 / Math.Pow(i, 2);

           Console.WriteLine($"Result: {res}");

           Console.ReadLine();

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота