В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
360Polina360
360Polina360
12.02.2022 20:55 •  Информатика

Нужно написать программу в паскаль. группу детей, приехавшую в оздоровительный лагерь, распределяют по по принципу: с 6 до 7 лет — 5-й отряд; с 8 до 9 лет — 4-й отряд; с 10 до 11 лет — 3-й отряд; с 12 до 13 лет — 2-й отряд; с 14 до 15 лет — 1-й отряд. составить программу, которая позволила бы каждому ребенку определять свой отряд.

Показать ответ
Ответ:
olesya12let
olesya12let
02.10.2020 14:44
{1 вариант}
var otr, vozr: byte;
begin
  writeln('введите возраст');
  readln(vozr);
  case vozr do
  6,7: otr:=5;
  8,9: otr:=4;
  10,11: otr:=3;
  12,13: otr:=2;
   14,15: otr:=1;
  end;
 writeln('Ваш отряд', otr);
end.

{2 вариант - более простой}
var otr, vozr: byte;
begin
  writeln('введите возраст');
  readln(vozr);
  otr:=5 - vozr div 2 + 3;
  writeln('ваш отряд', otr)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота