В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
FD140
FD140
11.09.2022 14:06 •  Информатика

Нужно написать программу на языке паскаль условие такое: вводится 15 чисел определить каких чисел кратных трём больше положительных или отрицательных

Показать ответ
Ответ:
finicot
finicot
04.10.2020 15:29
Var a,p,n,i:integer;
begin
 p := 0;
 n := 0;
 for i := 1 to 15 do
  begin
  read(a);
  if a mod 3 = 0 then
    if a > 0 then p := p + 1
    else
    if a < 0 then n := n + 1
  end;
  if p > n then writeln('Положительных') else
  if p < n then writeln('Отрицательных') else
    writeln('Одинаково')
end.

{вариант "как-то посложнее"}

var a,i,s:integer;
begin
 s := 0;
 for i := 1 to 15 do
  begin
  read(a);
  s := s + ord(a mod 3 = 0) * (ord(a > 0) - ord(a < 0))
  end;
 if s > 0 then writeln('Положительных') else
 if s < 0 then writeln('Отрицательных') else
 writeln('Одинаково')
end.   
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота