В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lizaivleva201
lizaivleva201
29.08.2020 02:44 •  Информатика

Нужно написать программу на языке кумира, которая создает массив из 10 целых случайных чисел с выводом на экран.

Показать ответ
Ответ:
Решение на Си:

#include <stdio.h>

int main() {

  int array[100]; // массив элементов
  int n, k, count = 0; // вс числа

  printf("Введите число для сравнения:");
  scanf("%d", &k); // запоминаем число для сравнения

  printf("\nВведите количество элементов:");
  scanf("%d", &n); // запоминаем количество элементов в массиве

  printf("\nВведите %d элементов: ", n);
  for (int i = 0; i < n; i++) {
     scanf("%d", &array[i]); // считываем массив

    if (array[i] > k) { // если число в массиве строго (!) больше нужного 
     count++; // то увеличиваем счётчик 
    }
  }

  printf("\n%d элементов больше, чем %d.", count, k); // выводим результат
 
return 0;
}
0,0(0 оценок)
Ответ:
DestapTM
DestapTM
29.08.2021 09:58

Линейными называются программы, состоящие из простых команд (операторов).

Простыми командами (простыми указаниями алгоритма) называются команды, которые не используют условия при своем исполнении. К числу простых операторов относятся команды (операторы) присваивания, ввода и вывода, вызова вс алгоритма (подпрограммы).Чаще для определения начальных значений удобнее пользоваться командой ввода, а не командой присваивания, потому что при необходимости использования программы с другими исходными данными не приходится менять текст программы.

Если в записи алгоритма стоит команда ввода, то его выполнение прерывается и управление передается программе, которая может осуществить ввод данных. После ввода данных управление передается следующей команде алгоритма.

На языке Паскаль процедура ввода данных имеет вид:

READ (список ввода);

READLN (список ввода).

При выполнении процедур READ и READLN программа переходит в состояние ожидания ввода данных. Если в списке ввода указано несколько переменных, то их можно вводить в одной строке, отделяя друг от друга символом «пробел», или в отдельных строках (в столбик), завершая ввод каждого значения клавишей Enter.

Оператор READLN отличается от оператора READ тем, что после введения необходимого числа данных курсор перемещается на следующую строку.

Если ввод данных осуществляется с клавиатуры, то список ввода - это список переменных, т.е. последовательность имен переменных, разделенных запятыми. Если ввод осуществляется из файла, то в списке ввода первая переменная - файловая, связана с именем реального файла.

Стандартные процедуры вывода результатов вычислений используются для вывода их значений на экран, принтер или в файл. На языке Паскаль процедуры вывода имеют вид:

WRITE (список вывода);

WRITELN (список вывода).Различие между WRITE и WRITELN заключается в том, что вывод оператором WRITE начинается с текущего местоположения курсора на экране монитора и курсор после окончания вывода остается в той же строке. Оператор WRITELN выводит значения с текущего места, а затем курсор перемещается на следующую строку. Можно использовать оператор WRITELN без списка вывода для перемещения курсора на новую строку.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота