Нужно написать программу на Java
Дана матрица размера M × N. Найти максимальный среди минимальных элементов ее строк. Есть код на Паскале
const
rows = 10; { <-- Количество строк }
columns = 10; { <-- Количество столбцов }
var
A: array[1..rows, 1..columns] of integer;
i, j, M, N: byte;
MinElem, MaxMinElem: integer;
begin
repeat
write('M = ');
readln(M)
until (M >= 1) and (M <= rows); { <-- Количество строк от 1 до rows }
repeat
write('N = ');
readln(N)
until (N >= 1) and (N <= columns); { <-- Количество столбцов от 1 до columns }
{ Формируем и выводим матрицу: }
randomize;
writeln('Случайная матрица ', M, 'x', N, ':');
for i := 1 to M do begin
for j := 1 to N do begin
a[i, j] := -100 + random(200); { <-- Случайный элемент -100..99 }
write(a[i, j]:4);
if j = 1 then MinElem := a[i, j] { <-- Инициализация минимального элемента }
else { Сравниваем остальные элементы с минимальным: }
if a[i, j] < MinElem then MinElem := a[i, j]
end;
if i = 1 then MaxMinElem := MinElem { <-- Инициализация максимального минимума }
else
if MinElem > MaxMinElem then MaxMinElem := MinElem;
writeln
end;
writeln;
writeln('Максимальный среди минимальных элементов строк: ', MaxMinElem);
readln
end.
#include <iostream>
using namespace std;
int main(){
setlocale(LC_ALL, "Russian");
int a;
cout<<"Введи размерность"<<endl;
cin>>a;
int arr[a+1][a+1];
for (int i=1; i<a+1; ++i)
for(int j=1; j<a+1; ++j)
arr[i][j]=i*j;
for (int i=1; i<a+1; ++i) {arr[i][0]=i;arr[0][i]=i;}
cout<<" ";
for (int i=1; i<a+1; ++i){cout<<arr[i][0]<<" ";}
cout<<endl;
for (int i=1; i<a+1; ++i){
for(int j=0; j<a+1; ++j)
cout<<arr[i][j]<<" ";
cout<<endl;
}
return 0;
}
Т.к. в условии про оформление ничего не сказано, то сделал самое обычное
Res, Simple: array[1..100] of integer;
Found:boolean;
Begin
for i := 2 to 200 do begin
found := false;
for j := 1 to simple_n do
found := found or (i mod Simple[j] = 0);
if found and (i mod 2 = 1) then begin
res_n := res_n + 1;
Res[res_n] := i;
writeln('Res = ',Res[res_n]:4);
end;
if not found then begin
simple_n := simple_n + 1;
Simple[simple_n] := i;
writeln('Simple = ',Simple[simple_n]:4);
end;
end;
for i := 1 to res_n do
write(Res[i]:4);
End.