Нужно написать программу на c++ :
треугольник называется равнобедренным, если хотя бы две из трех сторон имеют одинаковую длину. посчитайте количество равнобедренных треугольников, у которых длина каждой стороны - целое число от 1 до n. не забывайте, что треугольник существует только в том случае, когда длина каждой стороны меньше суммы длин двух сторон.
в единственной строке вводится одно натуральное число n.
выведите количество подходящих треугольников.
1. 1 ≤ n ≤ 100
2. 1 ≤ n ≤ 5000
3. 1 ≤ n 10⁶
подходящие треугольники:
1 1 1 / 2 2 1 / 2 2 2 / 2 2 3 / 3 3 1 / 3 3 2 / 3 3 3 / 3 3 4 / 4 4 1 / 4 4 2 / 4 4 3 / 4 4 4
//Pascal ABC.NET v3.0 сборка 1111
//1
Var
a,p,s:real;
begin
readln(a);
p:=a*4;
s:=a*a;
writeln('P=',p);
writeln('S=',s);
end.
//2
Var
a,b:integer;
begin
read(a,b);
if a>b then writeln(b);
if a=b then writeln('=');
if a<b then writeln(a);
end.
{На этом и закончу всем, кто когда либо и чем либо поддерживал данный проект. Думаю, он ещё многим послужит в критический момент. И я говорю не только про "списать домашку". Счастливо оставаться, господин Alviko. Может, ещё увидимся.
Ваш, Глеб 'I3artle' Косырев}
Приведём все степени к основанию 2
2^3702-2^468+2^1620-108
-108 можно представить как -128 + 16 + 4
2^3702-2^468+2^1620-2^7 + 2^4 + 2^2
Теперь выстраиваем степени в порядке убывания:
2^3702+2^1620-2^468-2^7 + 2^4 + 2^2
В выражении два вычитания подряд, избавимся от этого, заменив -2^468 на -2^469 + 2^468
2^3702+2^1620 -2^469+2^468-2^7 + 2^4 + 2^2
2^3702 - 1 единица
2^4 - 1 единица
2^2 - 1 единица
Количество единиц в вычитаниях будет равно разнице степеней. Например 1000000-100=1111
2^1620 -2^469 - количеств единиц 1620-469 = 1151
2^468-2^7 - количество единиц 468-7 = 461
Общее количество единиц равно 3+1151+461 = 1615