Нужно написать программу, которая будет хранить информацию о рейтинге фильмов. Для одного фильма может быть от нуля и более рейтингов. Каждый рейтинг содержит информацию об имени пользователя и его оценку от 0 до 10 Базовые данные для программы:
movies = {
"Django Unchained": {
"John": 10,
"Jack": 9
},
"Spider-Man": {}
}
Программа должна уметь:
Добавлять фильм:
пользователь вводит название, например "Interstellar", если его нет в списке фильмов, то программа выводит сообщение об успешном добавлении фильма:
"Movie added successfully"
если фильм уже есть, то вывести: “This movie already exist!”
Добавлять рейтинг к фильму
Пользователь вводит название, например "Interstellar"
Если фильм не существует, вывести сообщение
"This movie doesn't exist"
Если фильм существует, спросить пользователя два параметра: имя оценивающего и его оценку от 0 до 10.
Вывести на экран сообщение об успешном добавлении рейтинга:
A rating has been added for Interstellar: Rick rated it 9
Просматривать рейтинг для всех фильмов
Программа выводит средние рейтинги для всех фильмов
Interstellar is rated 7.7
Django Unchained is rated 9.5
Если рейтинга для фильма нет то выводить сообщение:
Rating is not yet available for movie_name
Указания:
В программе необходимо использовать бесконечный цикл для ввода команд.
Добавить пункт "Выход", который завершит программу.
Если пользователь вводит рейтинг, не попадающий в интервал от 1 до 10, выводить сообщение об ошибке и не добавлять этот рейтинг.
var q,s:integer;
begin
s:=1;
for q:=1 to 365 do
s:=s+q;
Writeln(s);
end.
Описание программы.
var q,s:integer; // Объявление переменных, где q - цикл от 1 до 365, s - сумма результата.
begin // Начало выполнение программы.
s:=1; // Присваиваем переменной s значение 1, т.к. по условию 1 рубль.
for q:=1 to 365 do // Цикл от 1 до 365
s:=s+q; // Сумма цикла. То есть - Сумма = Сумма + Цикл с шагом 1. Начальное значение s равно 1, поэтому сумма считывается больше суммы предыдущего дня.
Writeln(s); // Вывод результата.
end. // Конец выполнение программы.
Chat GPT – чат-бот на базі штучного інтелекту, який здатний спілкуватися в режимі реального часу, навіть у вигляді суперечки, а також за лічені секунди виводити помилки в коді та писати сценарії, вірші та текстовий контент. Технологію представила компанія OpenAI, одним із засновників якої був Ілон Маск.
Універсальний бот з'явився у листопаді 2022 року і одразу облетів увесь світ. Його реалізовували за до суперкомп'ютера Azure AI, а як мовну модель використовували технологію від OpenAI – GPT-3,5.
Цікавим був сам процес навчання Chat GPT. Для нього використовували систему зв'язку з людиною та величезний масив тексту, а потім переучували багато разів, використовуючи відповіді самого чат-бота. Таким чином, вдалося досягти ще коректніших результатів генерації. Розробники хотіли зробити його максимально “людським” і простим для взаємодії.
За даними аналітиків Bloomberg чат-бот універсальний. Його можна використовувати не тільки для написання тексту чи віршів, а й для:
проведення фінансового аналізу;
генерація простого коду;
вибудовування прогнозів;
резюм технічних статей;
створення персональних порад;
реалізації етичних відповідей