В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sugurbaeva2002
sugurbaeva2002
02.12.2022 01:02 •  Информатика

Нужно написать программу для циклического алгоритма с предусловием. вычислить количество отрицательных значений sin() на интервале [а, b] с заданным шагом.

Показать ответ
Ответ:
Laurka11
Laurka11
23.04.2020 12:33
Program name;//Имя программы
uses crt;//Запуск программы в консольном режиме НЕОБЯЗАТЕЛЬНО
var 
   a : Integer; 
b : Integer; 
i : Integer; 
c : Integer;
BEGIN //Начало программы 
write('Введите 1 число: ');  readln(a);//Ввод значения первого числа 
c := b-a-1;  write('Введите 2 число: '); 
readln(b);//Ввод значения второго числа 
writeln(a, ' ' , b); //Вывод двух чисел
  writeln(a, ' ' ,a*a,' ' , a*a*a); // Вывод 1 числа, квадрата, куба 
for i := 1 to b-a-1 do  
begin   
a := a + 1;   
writeln(a, ' ',a*a, ' ', a*a*a); // Вывод всех чисел от a до b 
end;         
writeln(b, ' ' ,b*b,' ' , b*b*b);// Вывод 2 числа, квадрата, куба 
ReadKey;  
end. //Конец программы
0,0(0 оценок)
Ответ:
NastjaKucera13
NastjaKucera13
04.04.2021 08:55
Хоспаде, чему вас там учат?
#include <iostream>
int main() {
   double a = 5.0, b;
   int c, d = 5;
   std::cin >> b >> d;
   a = a + b - 2;
   d = ++c - a + d;
   a *= c--;
   //Не знаю как это предполагалось записывать в одну строчку, поэтому юзаем чит.
   a /= 10 + 0 * (c /= 2) + 0 * (--b) + 0 * (d *= c + b + a);
   return 0;
}
Должно работать. Если не работает строчку перед return меняем на:
a /= 10 || c /= 2 || --b || d *= c + b + a;
Да, оно ничего не выводит. Ты не написал что оно должно выводить.
P.S. Если у вас не C++, а C меняешь std::cin >> b >> d; на scanf("%f", &a); и scanf("%f", &d); а вместо #include <iostream> пишешь #include <stdio.h>
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота